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1 Installation guide 

1.1 Before installing PcTool8620 on your computer - system requirements 

� Minimum hardware requirement 

� Intel CPU with minimum 1,7 GHz or comparable processor 

� 512 MB RAM 

� Approximately 50 MB free hard disk space 
 

� Minimum software requirement 

� OS Microsoft Windows 2000 / Windows XP 

� Microsoft .Net Framework 2.0 

� Microsoft Windows Installer 3.1 (see paragraph 1.2) 

 
 

1.2 Details for installation 

� Hardware 

� You may need more free hard disk space for installing further Device Descriptions. 
 

� Software 

� Windows Vista may be possible, but currently there is no official release. 

� If Microsoft .NET Framework 2.0 doesn’t exist on your computer, you have to install 
this software first. You can find Microsoft .Net Framework 2.0 on the official Microsoft 
homepage. 

� For installing Microsoft .NET Framework 2.0 you need minimum Microsoft Windows 
Installer 3.1. You can find Microsoft Windows Installer 3.1 also on the official Microsoft 
homepage. 

 
 
1.3 Installing PcTool8620 

� Proceeding 

� Execute setup file 

� Choose setup language and confirm with 

� Manage installation dialog with  

� Select installation directory 

� Choose components for installation 

� Select startup entry 

� Start installation by click at  

� Finish installation with 
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2 Working with PcTool8620 

2.1 Programm overview  

 
Figure 1: Screenshot PcTool8620 with sample project 

� Description of highlighted fields in Screenshot 

Menu / Tool bar - Used reference in Quickstart:→ menu item → menu sub item 

Project explorer - Navigation through project settings 

Project data window - Information and processing of project data 

Additional information - See following lines 

 Messages - Information about loading and importing files 

 Project validation 

- Detects and shows errors due to incorrect / required entries in project data 

- Double click on error message directs to fault position 

- Fast overview with additional information symbol in status bar 

 Context help - Additional information on input boxes in project data window 

 
 

- For using context help first open window ‘Context help’. Then click into input box in project data window to get 

further information on corresponding input box. 

Status bar 

Project explorer 

Additional information 

Project data window 

Menu / Tool 

bar 
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2.2 Before starting to work 

� Change program language by menu item 

→Extras  →Language / Sprache - Select program language 

 
- The new language will only be activated after next restart of application. 

 

� Select login level with icon  or by menu item 

→Login →Login ... 

- Select login level Operator or Specialist 

- Insert associated code (by default: Operator 0001 / Specialist 0002) 

- Confirm with 

Current login level is shown in the status bar. 

 

- Without login you are logged as guest. 

- For changing project data you need higher login level (Operator or Specialist). 

- Unavailable functions or input boxes will be grayed (font and / or background). 

 
 

2.3 Creating and editing projects 

� Create new project with icon  or by menu item 

→File →New project... 
 

 
You can find the device ID in the data sheet or at 

the type plate at the device! 

- Select according to your device the 

device ID and click   

- Select device description version 

matching to firmware version and 

create new project with . 

 

 

 

 

� Edit project data for project explorer sub-items in project data window 

Project settings for the new project have to be edited sub-item by sub-item of project explorer. 
See following table for short description of sub-items. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

                                                   
1
 Please note that control functions have more than one tab (Configuration, Parameter, ...). 

Sub-item Settings in project data window 

Project 
- Award configuration name (Displayed in device) 

- Insert project properties 

Overview - Block diagram of contemporary project 

Terminals - Wiring of inputs and outputs 

Inputs / Outputs 
- Selection and configuration of different input and 

output types 

Control functions 
- Selection, configuration and parameterization of 

control functions
1
 

Common device  

settings 

- Device language 

- Device display settings 

Data logging - Select sample time for data logging on SD card 

Files 

- Unsaved Files are labeled with * 

- Currently active parameter file is tagged by 

preceding > 

Figure 2: Example for project explorer (left) and sub-item explaining table 
(right) 
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2.4 Save projects 

� Save with icon  or by menu item 

→File →Save all - Save project, configuration and parameter file 

→File →Save project (as ...) - Save only project file (Choose new project file 

name and directory) 

→File →Save configuration file  - Save only configuration file  

From login level  

Specialist 

→File →Save active parameter file - Save only activated parameter file (Activate 

parameter file by right-clicking on it and choosing 

‘Define *.par as active parameter file) 

From login level 

Operator 

 

- Unsaved files are labeled in project explorer with *. 

- Files belonging to a project are saved by default in installation directory subfolder ‘Projects’. 

 
 

2.5 Use available data 

� Import existing configuration and parameter files into project 

→File →Import configuration file ... - Select the configuration file to be imported in 

dialog box  

From login level  

Specialist 

→File →Import parameter file ... - Choose the parameter file to be imported in dialog 

box 

From login level 

Operator 

 
- Imported file content is inserted into existing project configuration or parameter file. Previous content is permanently lost. 

 

� Attach more than one parameter file to project 

→File →Add existing parameter file  

... 

- Adds desired parameter file additionally to project. (Afterwards you 

can select between parameter files) 

 

2.6 Templates 

Easy and fast project building by using available files from device or from similar existing 
projects. 
 

- Create a new project (see paragraph2.3) 

- Import desired configuration and parameter file (see paragraph 2.5) 

- Complete data in sub-items ‚Project’, ‘Common device settings’, ‘Data logging’ and edit desired parameters and 

configuration items 

- Store complete project with ‚Save all’ 

 

- Don’t use ‚Save project as …’. Configuration and parameter file would belong to the old and simultaneous to the new 

project, while they exist only one time. Changes on files would have an effect on both projects. 
 

For using configuration or parameter file from device, you have to upload required files to SD 
card or via direct connection. Afterwards you can import files as described in paragraph 2.5. 
 

2.7 File transfer  

Device only operates with configuration file and related parameter file(s). 
 

Via SD card - Copy required files to SD card for following download into device 

Via direct connection →Device →Device Connection 

- Select 'Connection...' (according to equipment) 

- Login 

- Start Download  

 



   

   

 Quickstart PcTool8620 

 Online communication 
  

 

 
Page 8 

 

2.8 Project Conversion  

Converts  

• an existing old project to an updated version of the device description. 

• an existing project for one device ID to another device ID.  
 

The device description of the target device is required and needs to be installed in both cases. 
 

- Back-up your desired project before conversion.   

- Login with login level Specialist or higher.   

- Open your project →File →Open project  ... 

- Start conversion assistant →File →Convert project  ... 

- Follow assistant´s instructions. Proceed with “Next”.  

- If desired, select “Change device” and the new device ID. 

  Proceed with “Next”. 

 

- Select the desired version 

  of the device description.  

 

 

  Proceed with “Next”. 

 

- After conversion check the settings of the converted project.  

  Pay attention to message and project validation window. 

 

- Store complete project with ‚Save all’.  

 

 

 

Figure 3 : Project conversion: 
Selection of other device. 



   

   

Quickstart PcTool8620 
Online communication  

  
 

 

  

Page 9 

 

 

3 Communication PcTool8620 - Device 

3.1 Device preconditions 

� Device with one of the following configurations 

Device type             Connection Serial 
TCP/IP 
(Ethernet) 

Standard device �  

Standard device with Ethernet option � � 
 

� PC ( depending on connection ) with following equipment 

Serial � USB Port ( Driver installation for COM port necessary ) 

TCP/IP (Ethernet) � Ethernet Network Connection, TPC/IP port 10001 not locked by firewall(s). 
 

3.2 Establishing a connection via ... 

� Serial Interface 

� The virtual COM port driver "PL-2303" is already  installed 
2
 on the PC 

� The device is already powered up 

� PC and device are connected via USB connection cable  

� Start PcTool8620 (from Version V.1.0.0)  

→ Device → New device connection Select tab 'Serial'  

 

- Select virtual USB COM port   

If ‘AUTO’ was selected, PcTool8620 tries to identify a single USB-

connected 8620 device by requesting all available COM ports. 

Therefore firmware from Rev. B.99 is required. 

- Checkbox 'Standard settings' should be selected 

- Establish communication via 'Connect'  

- Login for further functionality (refer to chapter 3.3) 
 

� TCP/IP (Ethernet) 

� The device and the PC are connected to the net work.  

� The device is powered up and the Ethernet function is enabled. 

� Start PcTool8620 (from Version V1.0.0)  

→ Device → New device connection Select tab 'TCP/IP'  
 

- Input device IP. 

In case of using a non-static IP:  

 Input the configured DHCP host name.  

Therefore a DHCP server is required in the network. This DHCP 

server has to be configured to accept the device’s DHCP host 

name transmitted by the device (host) during IP address allocation.  

- Enable Standard settings 

- If  Standards settings were disabled:  

  Set timeouts for Connection und Communication  

- Establish Communication with 'Connect'  

- Login for further functionality (refer to chapter 3.3) 
 

 

                                                   
2
 If not, follow instructions in Chapter 3.4 "Installation of virtual COM-Port“  

Figure 4: Main menu

Figure 5: TCP/IP connection settings 
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3.3 Navigation with established device connection  

After successful login the following options are selectable in the navigation area. 
 

� Connection 

Connection ... Communication settings 

Device data ... Display of device and protocol information  

Login ... Change online login level. 

Logout Logout from current online login level. 
 

� Remote Control 

Start / Stop Start / Stop of remote control 

Show display ... 
Displays the active remote control screen, if 

another screen was selected in between. 

 

 
 

� Download (PC -> Device)  

Configuration file ... 

Parameter file ... 

Select file with    and then  

 

� Upload (Device -> PC) 

Configuration file ... 

Parameter file ... 

    . Afterwards select storage    

                               location on PC. 

Update datalog file list. Select datalog file and 

desired time range, afterwards start upload. 

Selected datalog file can be individually deleted 

from SD Card – online login level ‘Specialist’ is 

required.  

Datalog file ... 

 

Upload and store datalog files on PC 

before deleting from SD Card. 
 

� Service 

Firmware update ... via USB connection. 

- Use setting “Don´t Establish Serial connection” for 

updating devices that have a firmware revision less 

than B.99  

Download / Upload 

calibration file 

- for service purposes only 

(online login level ‘Master’ required) 

 
 

3.4 Installation of virtual COM port 

� Start installation of driver 'Prolific USB PL 2303'  

� Follow the instruction manual and finish the installation process. 
 

Connection settings for the COM port are set directly in the PcTool8620 (refer to chapter 3.2). 

Figure 6: Navigation area 
for device connection. 
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3.5 Device management 

Integrated device management simplifies remote device access by supporting a list of devices for 
establishing a new connection and an auto password function.  

Therefore the following data can be stored: 
� Master data:    Device location, device name, device ID, device serial, comments. 
� Connections:   Settings for serial and / or TCP/IP (Ethernet) access 
� Passwords:      For operator, specialist and master (stored encoded). 

 

� Enhancing / editing device management 

� Login into PC-Tool with code level ‘Operator’ (read only) or  ‘Specialist’ (for editing) 

→ Device → Open device management Select tab 'Device management'  
 

Adds a new device to device 

management. 

The currently selected device is … 

deleted from device 

management. 

edited.  

Edit data in the tabs Master data, 

Connections, Passwords. 

In editing mode … 

apply changes to device manag-

ement and exit editing mode. 

reject changed data and exit 

editing mode. 

After editing … 

Save device management changes.  

Each saving creates a separate 

backup file in the PC-Tool folder 

\AutoBackup with the curent content 

for later restoring. 
  

 

Restore an old version Import an existing version 

    

Restores an older auto backup version of the device 

management. 

Select the file to be restored.   

Auto backup files are labelled with their saving time stamp 

(YYYY-MM-DD hh:mm:ss). 

Imports an existing device management file, e.g.  

- from an older PC-Tool version (after an update) 

- from a colleague. 

Select the file to be imported and choose one of the import 

options. 

 
All changes since the last saving will be lost when restoring / importing a device management file! 

 
� Adding data from an existing connection to device management 

� Login into PC-Tool with code ‘Specialist’  

� Establish a connection to a device. 

� Go to item ‘Connection \ Device data …’ in the navigation bar and choose one of the following possibilities: 

Adds a new device to device management with the current 
connection settings.  
 

Copies the current connection data to the identified device 
in the device management. Existing data is overwritten. 
Check changes and press button ‘Apply’. A device is 
identified by combination of device ID and serial number. 

Figure 7: Device management. 
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� Establishing a connection via device management 

� Start PcTool8620 (from Version V.1.0.0)  

� Login into PC-Tool with at least code level ‘Operator’ 

→ Device → New device connection Select tab 'devices'  
 

- Select the device you want to connect with 

- Depending on device management data 

for the selected device, choose one of 

offered connections. 

- PC-Tool opens the corresponding tab and 

automatically fills the input boxes with 

settings from device management. 

- Select manually (last settings are kept): 

 ‘Serial connection: 

- COM-Port  

- Start the connecting process with 

‘Connect’ 

- For connection details refer to chapter 3.2, 

Establishing a connection via ... 

 

 

 

 
� Auto password function 

The auto password function copies the corresponding password into the login window after a 
connection was established and the login level was selected, if 

� the identified device exists only one time in the device management 
� and the corresponding password exists in the device management 
� and the application login level is higher than or equal to the desired device login level. 

 

Figure 8: Connection: List of devices. 
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4 Data evaluation 

The datalog file has to comply to datalogfile format Rev A.00 or higher for using the data 
evaluation functionality.  
 

4.1 Datalog file selection 

� Start PcTool8620 (from Version V.1.0.0)  

→ Data → New data evaluation Select tab 'File selection'  

 

- Add logfile(s) to Logfile selection with “Add …” 

- If the logfile(s) can be processed, the list items 

‘Datasets’, ‘Start’ and ‘End’ are filled with the 

corresponding values. 

- The data range for data display in tables and charts 

can be limited by setting the data range with ‘From’ 

and ‘To’ to the desired range. 

- For a new logfile selection clear the logfile selection 

list with “Remove all”. 

 
 
 
 
 
4.2 Quick view 

� Table 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 

- Table view of the read process data sets. 

Data sets are sorted according to 

ascending time stamp. 

- ‘Short names’ enables [Default] / disables 

short names for column labels in the table 

head 

Figure 9: Logfile selection 

Figure 10: Quick view Table 
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� Chart 

 
 

 
 
 
 
 
 
 
 
 
 
 
 

4.3 Custom view 

� Designer 

 
 

� Table 

Displays the data points, selected with the Designer in column “Table”, in list form.  
Data sets are sorted according to ascending time stamp. 

 
� Chart X 

Displays the data points, selected with the Designer in column “Chart X”.  
Axes are auto scaled. For further chart functionality refer to chapter 4.4. 

 
� All charts 

All charts are displayed with their individual settings on one tab. If the mouse was moved over one of 
these charts, a vertical time bar indicates the current time position in the other charts.  

 

- Overview chart  

   of all read process data sets.  

   Both axes are auto scaled. 

- Reducing displayed data curves by 

deselecting the corresponding curve in the 

explanation box. 

- For further chart functionality refer to 

chapter 4.4. 

Design several customized charts. 

- Select data points to be displayed in a 

separate data point table. 

- Add / delete designed charts.  

- Select for each chart the desired data 

points to be displayed. 

- Data point table and charts are displayed 

on separate tabs.   

Template  

Save current assignment of data points to 

table and charts in a file. 

Or load saved assignment of data points. 

Add chart 

Adds an additional chart to the designer. 

Delete chart 

Deletes the chart, which is selected in the 

left hand selection box. 

Short names 

enables [Default] / disables display of short 

names in the column ‘Data point’ 

Figure 11: Quick view Chart 

Figure 12: Custom view Designer 
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4.4 Chart functionality 

� Zoom 

 
 
 

� Move  

Move the displayed data area by keeping the right mouse button pressed and moving the 
mouse to the desired direction. 
 
� Change number of displayed data curves 

 
 

� Display options 

 
 
 

Menu item Functionality 

Update Selects all data curves in the explanation box 

Deselect all Deselects all data curves in the explanation box – for easy selection of desired data curves. 

Print Opens a dialog for printing the current chart. 

Export Opens a dialog for exporting the chart as a picture. 

Use the picture export only. Other offered export opportunities are senseless and might cause 

the PC Tool to shut down. 

Stairs mode Enabled [Default]: Forces the data points to be connected stairs like.  

Disabled:               Otherwise data points are connected by simple connection lines. 

Show points Enables [Default] / disables the display of each data point with a marker. 

Short names Enables [Default] / disables short names for the different data in explanation box. 

Title Enables [Default] / disables the display of the processed log file names as chart title. 

 

Zoom In  

  Mark the desired ‘zoom in area’ with 

drawing a rectangle from the left upper 

corner to the bottom right corner while 

keeping the left mouse button pressed. 

 

Zoom Out  

  Reset all ‘zoom in’ steps with drawing a line 

from the bottom right corner to the left 

upper corner while keeping the left mouse 

button pressed 

(De) select the corresponding data curve(s) in the explanation box. 

Figure 14: Explanation box. 

Figure 15: Chart menu..

Figure 13: Zoom In / Zoom out. 


